COVID-19 Update
Incident Report for TPP Wholesale Status Page
Resolved
This incident has been resolved.
Posted May 01, 2020 - 21:00 AEST
Monitoring
As concerns around the novel coronavirus (COVID-19) grow globally, the health and safety of our staff and community are the top priority for us. Therefore, we would like to assure you that we are committed to continuing to provide you the world-class services and products you require for you and your customers.
This week onwards, all TPP Wholesale staff are working from home until further notice. There will be no impact on our products and services provided. It is business as usual and our full Account Management team is here to help you.
Our support teams are also working as usual. However, given the ever changing situation, there may be an impact on support availability through certain channels in the near future. We will keep you posted about the developments on this front but at this stage it is business as usual with only the occasional delay during peak times.
Posted Mar 19, 2020 - 13:35 AEDT
This incident affected: TPP Wholesale Support Center (Live Chat, Help Desk).