Mail issue - cPanel Platform
Incident Report for TPP Wholesale Status Page
Resolved
This incident has been resolved.
Posted Apr 17, 2020 - 09:48 AEST
Identified
Please be advised that we are currently experiencing issues that affect incoming email for some customers hosted on our cPanel platform. Our technicians are looking into identifying and resolving these issues as fast as possible and we will provide updates as soon as they become available.
Posted Apr 15, 2020 - 17:24 AEST
This incident affected: cPanel Hosting (cPanel Email Services).