Resolved Issue: Phone Systems
Incident Report for TPP Wholesale Status Page
Resolved
This incident has been resolved.
Posted Apr 07, 2020 - 12:14 AEST
Identified
Good morning - we are aware of an issue affecting our phone systems & are looking into resolving this as a matter of urgency. Should you need to contact us, please visit support.tppwholesale.com.au as we are available on Chat and via Tickets. We'll issue an update soonest, thank you for your patience.

TPP Wholesale Support
Posted Apr 07, 2020 - 08:39 AEST
This incident affected: TPP Wholesale Support Center (Help Desk).