Support Update
Incident Report for TPP Wholesale Status Page
Resolved
Thank you for your patience over this period. Our Manila representatives are safe and able to continue providing great service.
Posted Feb 12, 2020 - 09:05 AEDT
Monitoring
Due to the on-going volcanic eruptions in Manila, we are likely to see some delays in our support turn-around across the next 48 hours. Please bear with us during this time, we’ll aim to post an update when available but at this moment our main concern is for our team’s safety.
Posted Jan 13, 2020 - 11:12 AEDT
This incident affected: TPP Wholesale Support Center (Live Chat, Help Desk).